ads

.,

Wednesday, 3 April 2013

juhry ann 20:29

Pembelajaran 1 : Setting Cisco Router ( konfigurasi sederhana )


Mumpung lagi hangat ngebahas tentang cisco router pada post sebelumnya : pengenalan router , saat ini saya ingin menambahkan cara setting network sederhana menggunakan cisco router. Sebelum berlanjut pada tahap setting men-setting ada baiknya saya tambahkan 1 lagi pengetahuan atau informasi yang berkaitan dengan setting network di cisco router. Sub bab ini belum ditambahkan pada posting saya sebelumnya. Isi dan konfigurasi yang saya muat di posting kali ini saya dapat dari seorang teman. yg sebelumnya faham betul  mengenai cisco Semoga artikel ini dapat bermanfaat buat rekan-rekan semua. Salam
ROUTING
Routing adalah proses dimana suatu router memforward paket ke jaringan yang dituju. Suatu router membuat keputusan berdasarkan IP address yang dituju oleh paket. Semua router menggunakan IP address tujuan untuk mengirim paket. Agar keputusan routing tersebut benar, router harus belajar bagaimana untuk mencapai tujuan. (lengkapnya)
Routing dibagi menjadi 2 tipe, routing  static dan routing  dinamic.
Perbedaan antara static dan dinamic :
1. Static routing
dikonfigurasi secara manual. Routing tabelnya diset manual dan disimpan dalam router. Tidak ada informasi sharing diantara sesama router. Hal ini mengakibatkan keterbatasan yang jelas karena ia tidak dapat secara otomatis menentukan route terbaik; ia selalu menggunakan rute yang sama yang kemungkinan bukan rute terbaik. Jika route berubah, static router harus diupdate secara manual. Karena static router menyediakan control penuh pada routing tabelnya, ia lebih aman dibanding dynamic router.
2. Dynamic routing
mampu membuat routing tabelnya sendiri dengan berbicara ke sesama router. Untuk melakukannya ia menemukan route dan route alternatif yang berada pada network. Dynamic router bisa membuat keputusan pada route yang mana sebuah paket mencapai tujuan. Umumnya ia mengirimkan paket ke route yang paling efisien; salah satu yang menghasilkan jumlah hop lebih sedikit. Bagaimanapun, jika route macet,dynamic route dapat mengirimkan paket ke route alternatif.




Pada kesempatan ini kita coba untuk yang static routing.berikut cara men-setting router seperti gambar di atas:
Router1 :
Press Enter to Start
Router>
Router>ena
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router1
Router1(config)#int s0
Router1(config-if)#ip addr 202.123.40.21 255.255.255.252
Router1(config-if)#clock rate 9600
Router(config-if)#no shut
%LINK-3-UPDOWN: Interface Serial0, changed state to up
Router1(config-if)#ex
%LINK-3-UPDOWN: Interface Serial0, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
Router1(config)#int e0
Router1(config-if)#ip addr 192.168.1.1 255.255.255.0
Router1(config-if)#no shut
%LINK-3-UPDOWN: Interface Ethernet0, changed state to up
%LINK-3-UPDOWN: Interface Serial0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
Router1(config-if)#ip route 192.168.2.0 255.255.255.0 202.123.40.21
Router1(config)#end
Route1r#wr mem
Building configuration…
[OK]
Router2:
Press Enter to Start
Router>ena
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router2
Router2(config)#int s0
Router2(config-if)#ip addr 202.123.40.22 255.255.255.252
Router2(config-if)#no shut
%LINK-3-UPDOWN: Interface Serial0, changed state to up
Router2(config-if)#ex
Router2(config)#int e0
Router2(config-if)#ip addr 192.168.2.1 255.255.255.0
Router2(config-if)#no shut
%LINK-3-UPDOWN: Interface Ethernet0, changed state to up
Router2(config-if)#ip route 192.168.1.0 255.255.255.0 202.123.40.22
Router2(config)#end
Router2#wr mem
Building configuration…
[OK]
PC Client01 :
ip addr 192.168.1.2
netmask 255.255.255.0
gateway 192.168.1.1
PC Client02 :
ip addr 192.168.2.2
netmask 255.255.255.0
gateway 192.168.2.1
Setelah settingan diatas dibuat, kemudian test ping dari PC Client01 ke PC Client02 dan sebaliknya!jika muncul reply berarti konfigurasi sukses, namun kalau belum bisa, coba sekali lagi. :)

Pengetahuan Dasar Cisco Router buat pemula


Semenjak membuat blog ini, sangat banyak artikel-artikel yang ingin saya tuangkan dalam blog ini, namun karena kurangnya waktu dan lain hal, maka isi dari blog ini akan saya tambahkan perlahan-lahan. Untuk posting saya yang kali ini tentang Cisco Router, merupakan keinginan dari dulu, dimana banyak manfaatnya untuk keperluan kerja saya dibidang IT, setidaknya dengan adanya post ini saya ga sulit2 klo mengingat ingat masa masa masih belajar cisco dulu yang sudah lebih kurang 4 th yang lalu. hehehe artikel ini saya dapat dari blog tetangga.  semoga artikel ini bermanfaat buat yang lain yang membutuhkan.
CISCO ROUTER
1. Pengantar
Tulisan ini ditujukan kepada pembaca tingkat pemula yang baru mempelajari networking. Oleh karena itu, bahasan-bahasan yang dipaparkan di sini hanyalah pengertian dasar router dan konfigurasi dasar saja.
2. Definisi Router
Router adalah sebuah device yang berfungsi untuk meneruskan paket-paket dari sebuah network ke network yang lainnya (baik LAN ke LAN atau LAN ke WAN) sehingga host-host yang ada pada sebuah network bisa berkomunikasi dengan host-host yang ada pada network yang lain. Router menghubungkan network-network tersebut pada network layer dari model OSI, sehingga secara teknis Router adalah Layer 3 Gateway. [1]
Router bisa berupa sebuah device yang dirancang khusus untuk berfungsi sebagai router (dedicated router), atau bisa juga berupa sebuah PC yang difungsikan sebagai router.
Dalam tulisan ini, saya hanya akan menulis tentang Cisco Router, yaitu sebuah dedicated router yang dibuat oleh Vendor bernama Cisco .
Oleh karena itu, setiap kata Router dalam tulisan berikutnya akan diartikan sebagai Cisco Router.
3. Network Interface
Network Interface adalah sebuah Interface yang berfungsi untuk menyambungkan sebuah host ke network. Network Interface adalah perangkat keras yang bekerja pada layer 1 dari Model OSI. Network Interface dibutuhkan oleh Router untuk menghubungkan Router dengan sebuah LAN atau WAN.
Karena Router bertugas menyambungkan network-network, sebuah router harus mempunyai minimal 2 network interface. Dengan konfigurasi minimal ini, router tersebut bisa menghubungkan 2 network, karena masing-masing network membutuhkan satu network interface yang terhubung ke Router.
4. Mengkonfigurasi Router
Router tidak mempunyai layar monitor untuk berinteraksi dengan network administrator, oleh karena itu, kita membutuhkan sebuah PC untuk men-setup sebuah router.
PC tersebut harus disambungkan ke router tersebut dengan salah satu dari cara berikut:
* melalui console port
* melalui Network
4.1. Men-konfigurasi Router melalui Port Console
Console port adalah sebuah port pada router yang disediakan untuk menghubungkan router tersebut pada “dunia luar”. Sebuah kabel Roll Over dibutuhkan untuk menghubungkan serial interface pada PC dan Console port pada router tersebut.
Setelah Router terhubung dengan PC, Router dapat dikonfigurasi dengan menjalankan applikasi HyperTerminal dari PC. [2]
4.2. Men-konfigurasi Router melalui Network
Dengan cara ini, Router dapat dikonfigurasi dengan PC yang terhubung dengan Router melalui network. Cara ini hanya bisa digunakan untuk melihat konfigurasi dan memodifikasi konfigurasi pada router.
Mengapa ? Karena sebuah router hanya akan terhubung ke network jika Network Interface-nya sudah terkonfigurasi dengan benar.
Di sisi lain, cara ini juga mempunyai kelebihan. Dengan cara ini, network administrator lebih leluasa menempatkan PC-nya untuk memodifikasi konfigurasi router. Network administrator bisa menempatkan PC-nya di mana saja, asalkan PC tersebut bisa terhubung ke Router melalui jaringan.
Dengan cara ini, Network administrator membutuhkan applikasi telnet untuk mengkonfigurasi Router tersebut.
Berikut adalah langkah-langkah menggunakan telnet pada PC dengan Sistem Operasi Windows:
* Jalankan command prompt (atau MS DOS prompt pada Windows 9x)
* Ketik perintah berikut pada command prompt:
C:\> telnet IP-address-Router
Contoh:
C:\> telnet 172.16.148.1
4.3 Inisialisasi Konfigurasi Router
Konfigurasi Router disimpan pada sebuah memory spesial pada router yang disebut nonvolatile random-access memory (NVRAM). Jika tidak ada konfigurasi yang tersimpan pada NVRAM, maka system operasi pada Router akan menjalankan sebuah routine yang akan memberikan pertanyaan-pertanyaan yang jawabannya akan digunakan untuk mengkonfigurasi router tersebut.
Routine ini dalam kosakata Windows dikenal dengan nama Wizard. Namun pada Router Cisco, routine ini disebut dengan nama system configuration dialog atau setup dialog.
Setup Dialog ini hanya dirancang untuk membuat konfigurasi minimal, karena tujuan utama dari mode setup ini hanyalah untuk membuat konfigurasi secara cepat dan mudah.
Untuk konfigurasi yang komplex, network administrator harus melakukannya secara manual.
Setup Dialog bisa juga dipanggil walaupun NVRAM sudah berisi konfigurasi. Administrator cukup mengetik command setup pada CLI (Command Line Interface) dan Setup Dialog akan dieksekusi.
Berikut adalah contoh pemanggilan Setup Dialog dari CLI.
4.4 Tingkat akses perintah
Untuk tujuan keamaan, perintah-perintah yang bisa dijalankan dari CLI dibagi menjadi 2 tingkat akses, yaitu:
· User Mode
· Privileged Mode
User Mode ditujukan untuk melihat status router. Perintah-perintah yang diizinkan pada mode ini tidak bisa mengubah konfigurasi router, sehingga mode ini lebih aman ketika seorang network administrator hanya ingin melihat status router dan tidak ingin mengubah konfigurasi.
Privileged Mode mempunyai tingkat akses yang lebih tinggi. Dengan mode ini, network administrator bisa mengubah configurasi router. Oleh karena itu, mode ini sebaiknya digunakan dengan hati-hati sekali untuk menghindari perubahan yang tidak diinginkan pada router tersebut.
Saat log on ke router pertama kali, anda akan masuk pada user mode, dengan prompt berupa tanda (>).
Untuk berpindah dari user mode ke priviledge mode, anda harus mengeksekusi perintah enable pada prompt. Prompt akan berubah menjadi tanda (#) ketika anda berada pada Privilged mode.
Untuk kembali ke user mode dari priviledge mode, anda harus mengeksekusi perintah disable pada command prompt.
Contoh 4.4-1:
router con0 is now available
Press RETURN to get started
router >
router > enable
router # disable
router >
router > logout
4.5. Mengubah Konfigurasi Router
Seperti telah disinggung di bab 4.4, Setup Dialog tidak dirancang untuk memodifikasi Konfigurasi Router ataupun membuat Konfigurasi Router yang komplex. Oleh karena itu, untuk keperluan ini, harus dilakukan secara manual dengan memasuki Mode Konfigurasi.
Pengubahan konfigurasi ini bisa dilakukan langsung melalui console atau secara remote melalui jaringan seperti telah diulas pada Bab 4.1 dan 4.2.
Setelah PC terhubung ke router, maka network administrator harus memasuki Privileged Mode dulu seperti yg telah disinggung dalam Bab 4.4.
Akhirnya, konfigurasi dapat diubah dengan perintah configure terminal untuk memasuki global configuration mode yang kemudian diikuti dengan baris-baris konfigurasi.
Setelah baris-baris configurasi dituliskan, perintah exit akan diperlukan untuk keluar dari global configuration mode.
Contoh 4.5-1: mengubah konfigurasi router
router con0 is now available
Press RETURN to get started
router >
router > enable
router # configure terminal
router (config) # interface ethernet 0
router (config-if) # description IT Department LAN
router (config-if) # exit
router (config) # exit
router #
5. Mengamankan router dengan password
Untuk menyulitkan orang yang tidak berhak mengubah dan mengacau konfigurasi router, maka router tersebut perlu dilindungi dengan kata sandi (password).
5.1 Password untuk console
Jika password diaktifkan pada console, maka user tidak bisa begitu saja mendapatkan akses ke router melalui console tanpa menuliskan password console terlebih dahulu.
Untuk melakukan hal ini, diperlukan perintah line console 0 diikuti dengan perintah login dan password dalam konfigurasi router.
Contoh 5.1-1: membuat password untuk console
Router(config) # line console 0
Router(config-line) # login
Router(config-line) # password coba
Router(config-line) # exit
Router(config) # exit
Router(config) #
Router yang dikonfigurasi seperti contoh 5.1-1 akan meminta password ketika user mencoba mendapatkan akses melalui console. Dan passwordnya adalah coba.
5.2 Password untuk Virtual Terminal
Virtual Terminal ini akan digunakan ketika user ingin mendapatkan akses melalui jaringan dengan applikasi telnet. Password Virtual Terminal ini harus dikonfigurasi sebelum user bisa mendapatkan akses melalui jaringan. Tanpa password, koneksi melalui jaringan akan ditolak oleh router dan router akan memberikan pesan berikut:
Password required, but none set
Contoh 5.2-1 memperlihatkan bagaimana caranya mengkonfigurasi password pada Virtual Terminal.
Contoh 5.2-1:
Router(config) # line vty 0 4
Router(config-line) # password cobain
Router(config-line) # exit
Router(config) # exit
Router(config) #
Pada contoh 5.2-1, router akan meminta password ketika diakses lewat jaringan. Dan password untuk virtual terminal tersebut adalah cobain.
Angka 0 pada baris line vty 0 4 menunjukkan nomer awal virtual terminal, dan angka 4 menunjukkan nomer terakhir dari virtual terminal. Oleh karena itu, perintah tersebut memperlihatkan bahwa router tersebut mengizinkan 5 koneksi melalui virtual terminal pada waktu yang bersamaan.
5.3 Password untuk mode priviledge
Setelah user menuliskan password dengan benar untuk mendapatkan akses ke router baik melalui jaringan ataupun console, maka user akan memasuki user mode.
Jika password untuk mode priviledge dikonfigurasi, maka user juga harus menuliskan password lagi untuk masuk ke mode itu.
Perintah yang digunakan untuk memberi password pada mode ini adalah enable password, atau enable secret.
Perbedaan antara kedua perintah tersebut adalah bahwa perintah enable secret membuat password-nya terenkrip sedangkan enable password tidak.
Kedua perintah tersebut juga bisa dituliskan kedua-duanya dalam mode konfigurasi global, dan keduanya juga bisa mempunyai password yang berbeda.
Namun jika keduanya diletakkan pada konfigurasi, maka password pada enable secret yang akan digunakan untuk memasuki privileged mode.
Contoh 5.3-1: mengkonfigurasi enable password
Router(config) # enable password rahasia
Contoh 5.3-2: mengkonfigurasi enable secret
Router(config) # enable secret rahasiabanget
Dalam konfigurasi router, sebuah perintah bisa dihapus dengan menambahkan perintah no pada mode konfigurasi. Dengan demikian, untuk menghapus password pada contoh 5.3-2 dapat dilakukan dengan perintah seperti yang tampak pada contoh 5.3-3.
Contoh 5.3-3: menghapus password enable secret
Router(config) # no enable secret rahasiabanget
6. Mengkonfigurasi Interface
Seperti telah dipaparkan pada bab 2 dan Bab 3, tugas router adalah meneruskan paket-paket dari sebuah network ke network yang lainnya. Sebuhungan dengan tugas tersebut, network interface harus dikonfigurasi sesuai dengan karakteristik-nya.
Perintah interface pada mode konfigurasi global disediakan untuk mengkonfigurasi interface-interface pada router. Ada berbagai tipe interface yang dikonfigurasi dengan perintah ini antara lain: Ethernet, Token Ring, FDDI, serial, HSSI, loopback, dialer, null, anync, ATM, BRI, dan tunnel.
Dalam tulisan ini, hanya Ethernet dan Serial saja yang akan dibahas lebih lanjut.
6..1. Mengkonfigurasi Ethernet Interface
Seperti telah dijelaskan di atas, perintah interface harus dijalankan pada mode konfigurasi global. Untuk memasuki mode konfigurasi global, gunakan perintah configure terminal, seperti yang telah dijelaskan pada bab 4.5.
Format perintah interface untuk memasuki mode konfigurasi interface untuk Ethernet pada router yang hanya mempunyai satu slot adalah:
interface ethernet nomer-port
Beberapa jenis router memiliki banyak slot, seperti misalnya Cisco 2600,3600 dan 4000. Untuk router-router dengan banyak slot, format perintahnya adalah:
interface ethernet nomer-slot/nomer-port
Setelah memasuki mode konfigurasi interface dengan perintah di atas, barulah Ethernet tersebut dapat dikonfigurasi sesuai dengan kebutuhan.
Konfigurasi paling dasar yang dibutuhkan agar Ethernet dapat meneruskan paket-paket adalah IP address dan subnet mask. [3]
Format konfigurasinya adalah:
ip address IP-address subnet-mask
Contoh 6-1-1: contoh konfigurasi interface ethernet
Router# configure terminal
Router(config)# interface ethernet 1/0
Router(config-if)# description LAN pada Department IT
Router(config-if)# ip address 172.16.148.1 255.255.255.128
Router(config-if)# exit
Router(config)# exit
Router#
6.2. Mengkonfigurasi Serial Interface
Serial interface adalah interface yang seringkali digunakan untuk koneksi ke WAN (Wide Area Network). Koneksi serial membutuhkan clocking untuk sinkronisasi. Dan oleh karena itu, hubungan serial ini harus mempunyai 2 sisi, yaitu DCE (data circuit-terminating equipment_ dan DTE (data terminal equipment). DCE menyediakan clocking dan DTE akan mengikuti clock yang diberikan oleh DCE. Kabel DCE mempunyai koneksi female (perempuan), sedangkan kabel DTE mempunyai koneksi male (jantan).
Pada prakteknya, DCE biasanya disediakan oleh service provider yang biasanya adalah merupakan koneksi ke CSU/DSU. Router sendiri biasanya hanyalah berperan sebagai DTE sehingga router tersebut tidak perlu menyediakan clocking.
Walaupun demikian, cisco router juga bisa berperan sebagai DCE yang menyediakan clocking. Fungsi ini biasanya dipakai untuk uji coba router dimana kita bisa menghubungkan 2 buah router back to back sehingga salah satu router harus berfungsi sebagai DCE agar koneksi bisa terjadi.
Contoh 6.2-1: contoh konfigurasi interface serial sebagai DTE
Router # configure terminal
Router(config)# interface serial 0
Router(config-if)# description WAN ke Natuna
Router(config-if)# ip address 172.16.158.1 255.255.255.252
Router(config-if)# bandwith 64
Router(config-if)# exit
Router(config)# exit
Router#
Contoh 6.2-2: contoh konfigurasi interface serial sebagai DCE
Router # configure terminal
Router(config)# interface serial 0
Router(config-if)# description Lab Cisco sebagai DCE
Router(config-if)# ip address 172.16.158.1 255.255.255.252
Router(config-if)# bandwith 64
Router(config-if)# clock rate 64000
Router(config-if)# exit
Router(config)# exit
Router#
6.3 Men-disable sebuah interface
Kadangkala kita perlu mematikan/mendisable sebuah interface untuk keperluan troubleshooting ataupun administratif.
Untuk keperluan tersebut, dapat digunakan perintah shutdown pada interface yang bersangkutan. Dan untuk menghidupkannya kembali, dapat digunakan perintah no shutdown.
Contoh 6.3-1: mematikan interface
Router(config)# interface serial 0
Router(config-if)# shutdown
Router(config-if)# exit
Router(config)#
Contoh 6.3-2: menghidupkan interface
Router(config)# interface serial 0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)#
7. Routing
Akhirnya, setelah interface terkonfigurasi, router memerlukan sebuah proses agar router tahu bagaimana dan kemana sebuah paket harus diteruskan. Proses ini disebut proses routing.
Routing dapat dikelompokkan menjadi 2 kelompok, yaitu:
· Static Routing – Router meneruskan paket dari sebuah network ke network yang lainnya berdasarkan rute (catatan: seperti rute pada bis kota) yang ditentukan oleh administrator. Rute pada static routing tidak berubah, kecuali jika diubah secara manual oleh administrator.
· Dynamic Routing – Router mempelajari sendiri Rute yang terbaik yang akan ditempuhnya untuk meneruskan paket dari sebuah network ke network lainnya. Administrator tidak menentukan rute yang harus ditempuh oleh paket-paket tersebut. Administrator hanya menentukan bagaimana cara router mempelajari paket, dan kemudian router mempelajarinya sendiri. Rute pada dynamic routing berubah, sesuai dengan pelajaran yang didapatkan oleh router.
Dynamic Routing tidak dibahas dalam tulisan ini karena walaupun konfigurasi-nya cukup mudah, namun bagaimana cara routing tersebut bekerja saya anggap sebagai topik lanjutan sehingga tidak saya bahas pada tulisan ini.
Static Routing dapat dilakukan dengan memasukkan baris ip route pada mode konfigurasi global.
Adapun format penulisan baris tersebut adalah:
ip route network [mask] {alamat | interface }
dimana:
* network adalah network tujuan
* mask adalah subnet mask
* alamat adalah IP address ke mana network akan dilewatkan
* interface adalah nama interface yang digunakan untuk melewatkan paket yang ditujukan
Gambar 7-1: Contoh routing
Gambar di atas memperlihatkan sebuah LAN yang terhubung ke WAN melalui 2 buah router, yaitu router A dan router B.
Agar LAN tersebut bisa dihubungi dari WAN, maka router A perlu diberikan static routing dengan baris perintah seperti berikut:
RouterA(config)# ip route 172.16.10.0 255.255.255.0 172.16.158.1
Dan agar router B bisa meneruskan paket-paket yang ditujukan ke WAN, maka router B perlu dikonfigurasi dengan static routing berikut:
RouterB(config)# ip route 0.0.0.0 0.0.0.0 172.16.158.2
8. Menyimpan dan mengambil Konfigurasi
Berbagai konfigurasi yang telah kita tuliskan dengan perintah configure terminal hanya akan disimpan pada RAM yang merupakan memory volatile. Jika konfigurasi ini tidak disimpan di NVRAM, maka konfigurasi tersebut akan hilang ketika router dimatikan atau direstart.
Secara default, Router akan mengambil konfigurasi dari NVRAM saat start up, meletakkannya di RAM, dan kemudian menggunakan konfigurasi yang ada pada RAM untuk beroperasi.
Untuk menyimpan konfigurasi yang ada di RAM ke NVRAM, diperlukan baris perintah berikut pada privileged mode:
Router# copy running-config startup-config
Sebaliknya, untuk mengambil konfigurasi yang ada di NVRAM dan meletakkannya pada RAM, dapat digunakan perintah berikut pada privileged mode:
Router# copy startup-config running-config
Dan untuk melihat konfigurasi yang sedang beroperasi (pada RAM), dapat digunakan perintah show running-config pada privileged mode.
Contoh 8-1: melihat running-config
Router# show running-config
Building configuration…
Current configuration : 4479 bytes
!
! Last configuration change at 12:23:26 UTC Fri Oct 10 2003
!
version 12.2
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname jakarta-lina
!
…. Dan selanjutnya …..
9. Beberapa Tips
Bekal pengetahuan dasar pada bab-bab di atas sebenarnya telah cukup berguna untuk segera memulai percobaan-percobaan dan mempelajari router lebih lanjut.
Namun untuk melengkapi dan memudahkan proses belajar, ada baiknya anda juga mengetahui beberapa tips agar mudah mengetahui perintah-perintah apa saja yang bisa dijalankan dan format penggunaannya.
9.1 Mengetahui perintah apa saja yang bisa dijalankan
Pada mode apa saja, anda bisa mengetikkan tanda (?) pada prompt. Dengan mengetikkan tanda tersebut, router akan memberitahukan apa saja yang bisa anda tuliskan pada prompt tersebut.
Contoh 9.1-1: melihat perintah-perintah apa saja yang berlaku pada prompt
router> ?
Exec commands:
<1-99> Session number to resume
access-enable Create a temporary Access-List entry
access-profile Apply user-profile to interface
clear Reset functions
connect Open a terminal connection
disable Turn off privileged commands
disconnect Disconnect an existing network connection
enable Turn on privileged commands
exit Exit from the EXEC
help Description of the interactive help system
lat Open a lat connection
lock Lock the terminal
login Log in as a particular user
logout Exit from the EXEC
mrinfo Request neighbor and version information from a multicast
router
mstat Show statistics after multiple multicast traceroutes
mtrace Trace reverse multicast path from destination to source
name-connection Name an existing network connection
pad Open a X.29 PAD connection
ping Send echo messages
ppp Start IETF Point-to-Point Protocol (PPP)
resume Resume an active network connection
rlogin Open an rlogin connection
show Show running system information
slip Start Serial-line IP (SLIP)
systat Display information about terminal lines
tclquit Quit Tool Comand Language shell
tclsh Tool Comand Language a shell
telnet Open a telnet connection
terminal Set terminal line parameters
traceroute Trace route to destination
tunnel Open a tunnel connection
udptn Open an udptn connection
where List active connections
x28 Become an X.28 PAD
x3 Set X.3 parameters on PAD
router>
contoh 9.1-2: melihat perintah apa saja yang dimulai dengan huruf “t”
router> t?
tclquit tclsh telnet terminal traceroute
tunnel
router> t
contoh 9.1-3: melihat lanjutan dari sebuah perintah
router>telnet ?
WORD IP address or hostname of a remote system
router>telnet
9.2 Perintah yang tidak lengkap dan Auto Completion
Sebuah perintah pada router tidak harus dituliskan secara lengkap jika perintah tersebut tidak ambiguous. Dengan fasilitas ini, administrator bisa menghemat waktu karena tidak harus mengetikkan semua perintah secara lengkap.
Contoh 9.2-1: perintah yang tidak lengkap
Router # sh ru
Building configuration…
Current configuration : 4479 bytes
!
! Last configuration change at 12:23:26 UTC Fri Oct 10 2003
!
……… dan selanjutnya ………
Tampak pada contoh 9.2-1 bahwa router menjalankan perintah show running-config, padahal administrator hanya menuliskan sh ru pada prompt.
Kadangkala kita tidak yakin dengan sebuah command sehingga kita tidak berani menuliskannya dengan tidak lengkap seperti di atas. Dengan kondisi seperti ini, administrator juga bisa menghemat waktu pengetikan dengan menekan tombol dan router akan melakukan auto completion.
Contoh 9.2-2: auto completion
Router > tel
Router > telnet
Contoh 9.2-2 memperlihatkan bahwa administrator cukup mengetikkan tel + dan router melengkapinya sendiri menjadi telnet setelah penekanan tombol .
10. Contoh Configurasi Sederhana
Akhirnya, tulisan ini akan saya tutup dengan memberikan contoh sebuah konfigurasi router sederhana secara utuh. Dan saya ucapkan selamat belajar.
Contoh 10-1: konfigurasi sederhana secara utuh
trident16-rig#sh run
Building configuration…
Current configuration:
!
! No configuration change since last restart
!
version 12.1
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname trident16-rig
!
enable secret 5 $1$PlKA$Ev/ev3/gQJHnytqacioZt.
!
ip subnet-zero
no ip domain-lookup
ip name-server 192.23.168.5
ip name-server 192.23.164.5
!
interface Ethernet0
description Local Segment for Trident 16 Rig
ip address 172.16.135.1 255.255.255.192
!
interface Serial0
description VSAT link to jakarta-lina-sat
bandwidth 128
ip address 172.16.158.174 255.255.255.252
!
interface Serial1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.158.173
no ip http server
!
line con 0
transport input none
line aux 0
line vty 0 4
password 7 023616521D071B240C600C0D12180000
login
!
end
trident16-rig#
Description: CISCO- Cisco Router ( konfigurasi sederhana ) dari tidak tahu menjadi tahu
Reviewer: juhry ann
Rating: 4.0
ItemReviewed: CISCO- Cisco Router ( konfigurasi sederhana ) dari tidak tahu menjadi tahu

No comments: